Suchitra Vipin
Suchitra Vipin
Computer Science
06 Jun 2018

I want to use laravel framework. My System is installed with apache on port 81. But my laravel application shows the url as 127.0.0.1:8000. It is not working. What will be the solution?

06 Jun 2018

Welcome to CE, @Suchitra‍ . I work on Laravel as well and may try to address your question. 

I see that the problem is with your apache port. Normally apache runs on port 80. You will have to configure it to run on 8000 or 80. If you do set it on 8000 then your current url: `127.0.0.1:8000` will work fine. 

Are you using Valet or XAMPP to run Laravel? You should look for Apache port settings. 

Does that help? 

Anna Parker

Anna Parker

Computer Science
06 Jun 2018

Yes you need to change it form port 81 to port 80 for it to work fine. 

I use Valet on windows 10 for laravel application. It bit easy I suppose. 

Suchitra Vipin

Suchitra Vipin

Computer Science
06 Jun 2018

@Kaustubh‍ Thank you for the time and reply

06 Jun 2018

You're welcome. Did that solution work? 

Suchitra Vipin

Suchitra Vipin

Computer Science
06 Jun 2018

@Kaustubh‍  i changed the port to 8000 and tried  .. But not working.. :(.. Url shows loading only for a long time

06 Jun 2018

That looks like a strange problem. Could you tell us a bit about your configuration? 

  1. Are you using Valet or Xampp to setup your local server?
  2. Could you add a screenshot of your apache settings? 
  3. Does a normal php file load fine?

You may try with a simple file in the web root directory -

<?php phpinfo(); ?>

Is there any error being thrown in the Laravel log? Some more information would definitely help fixing this issue. 


Share this content on your social channels -

Only logged in users can reply.