View Feed
group-icon
Coffee Room
Discuss anything here - everything that you wish to discuss with fellow engineers.
12793 Members
Join this group to post and comment.
friendster7
friendster7 • Feb 3, 2008

problem in turboc

guys i have a problem..i cannot use turboc compiler to compile a computer graphics program in my PC..i am using AMD 3600+ processor and nvidia motherboard..do any one help me with this..

and anyone using AMD processor experienced this problem..
do reply..
mahul
mahul • Feb 16, 2008
please supply more details, like whether u have included the graphics library in the settings etc, also tell us the message that shows up when u try to compile a graphics program. i assume u r using the graphics.h library.
Prasad Ajinkya
Prasad Ajinkya • Feb 16, 2008
Hey friendster,

Have you given the correct path to your linker?
komputergeek
komputergeek • Oct 21, 2008
1.Start TurboC
2.Then start task manager
3.Goto the process of TurboC
4.Right click on that process and then click on Set Affinity
5.It will show you one small window with list of checkboxes with labels CPU1,CPU2,.... Uncheck CPU2 and now try compiling the program

Works only for some hardware configurations.
xero
xero • Oct 22, 2008
well if this problem is only with graphics, it should be some library issue.
Even I've a PC with AMD 4200 and nvidia 8800GT. Although i've never tried running a graphics application! If possible try to run some default graphics programs which comes with it.
komputergeek
komputergeek • Oct 22, 2008
This problem is not because of library files.Turo C is a 16 bit
compiler.Both processors try to share load and thats the problem.Even old 16 bit games like DAVE do not work on these systems.
So try using only one processor for that.Do this by 'Set Affinity'
option in task manager.
xero
xero • Oct 23, 2008
No kgeek, I don't buy that, all AMD 64 bit dual CORE processors follow the x86 architecture.

Now regarding the DAVE,a 16 bit graphic application. WinXp support 16 bit gfx applications due to lack of gfx libraries. It has nothing to do with processor type. By the way, try to run DAVE under NTVDM. This is a process that windows provides 16 bit emulation dos equivalent to a win 3.x. The only problem is it doesn't provide direct access to memory and hardware. So those apps which require direct access to mem or h/w won't run. And i strongly feel this will encorporate the gfx apps 😀

Now Mr Friendster what else have you tried to make the app run?

Share this content on your social channels -