View Feed
Coffee Room
Discuss anything here - everything that you wish to discuss with fellow engineers.
12913 Members
Join this group to post and comment.
Kaustubh Katdare
Kaustubh Katdare • Aug 11, 2017

BSNL connectivity issues - can ping but can't browse

I've began facing a strange issue on the BSNL network (FTTH). Some of the sites that I used to access daily (including some of our own test servers) aren't accessible anymore. The interesting thing is that I can ping these servers and get a response, however when I try to access them using browser, I get the following error message:

This site can’t be reached
The connection was reset.

  • Checking the connection
  • Checking the proxy and the firewall
  • Running Network Diagnostics

I've already tried altering the DNS but didn't work. I thought the DNS cache could be a problem and cleared it on my machine - still didn't help.

What's working though is accessing these sites using mobile data connection. I can connect to the sites using Jio's mobile network, but that connection isn't useful for all my regular upload and download activities.

I've faced this issue in the past but can't recall the exact way I fixed it. Would really appreciate if someone can help with it. If it's all from BSNL's side, I hope they resolve it.
Abhishek Rawal
Abhishek Rawal • Aug 12, 2017
Are you using Google Chrome ? Did you try another browser ? Which version of browser is it ?
Can you open chrome://net-internals/ and click on sockets, flush the socket pools and flush cookies dns cache and restart browser and check again.

Additionally you can take tcpdump and trace the packets to find the root cause of the issue.
Kaustubh Katdare
Kaustubh Katdare • Aug 12, 2017
@Abhishek Rawal - Thanks. The problem auto-resolved. Looks like BSNL servers go mad at times. But that information is going to be super useful. Thanks!

Share this content on your social channels -