CrazyEngineers Archive
Old, but evergreen and popular discussions on CrazyEngineers, presented to you in read-only mode.
@Kaustubh Katdare • 06 Jul, 2014
Since last ~2 days, YouTube's constantly showing "An error occurred. Please try again later. Read More" message on any video that I try to access on YouTube. Allow me to explain the setup because I strongly think it's dependent on it:- My Modem Connects To Router which creates a Wi-Fi hot-spot. I use a Range Extender to extend the range of the network. My laptop and phone use this extended network to connect to the Internet. Now following are the observations I've made so far.
  1. Any device connected to the extended network show the above error message - I tried using Laptop and also my phone.
  2. I thought that the problem would be with the range extender; but it appears that even on the network of the main router, YouTube does not work (same error message appears).
  3. Surprisingly, though - YouTube works fine on the Desktop that connects to the network of the main router and I can watch videos.
I'm totally unable to figure out what's exactly wrong. I first thought it was some issue with the cookie settings, flash software or javascript; but then found that my Android phone too exhibits the same problem. I've searched almost entire Internet but there's no solution to the issue.

Update: I checked from another android and it offered more surprises. m.youtube.com does not show videos but they play fine on the YouTube App. I'm now wondering if there's anything I need to fix or it's a service issue from YouTube itself. I remember I did not install anything on my phone or laptop that might have caused the issue.

Would really appreciate if anyone can suggest a fix for this problem.
@Rajat Motwani • 07 Jul, 2014 BSNL?
@Kaustubh Katdare • 07 Jul, 2014
Rajat Motwani
BSNL?
Yes, BSNL connection.
@Rajat Motwani • 07 Jul, 2014
Kaustubh Katdare
Yes, BSNL connection.
Try Changing your DNS, Use Google Public DNS, will solve your issue, worked for me!
its: 8.8.8.8
and 8.8.4.4
@Kaustubh Katdare • 07 Jul, 2014 • 1 like
Rajat Motwani
Try Changing your DNS, Use Google Public DNS, will solve your issue, worked for me!
its: 8.8.8.8
and 8.8.4.4
Thanks. I was using Google DNS for quite a long time and then it had issues. I had to switch to default BSNL DNS because that was the only 'fix' offered by the BSNL technicians. Just set my DNS back to Google and will check how it works out. Thanks a lot for your help, @Rajat Motwani !
3.6k views

Related Posts

@Ankita Katdare · Jan 9, 2016

BHEL or Bharat Heavy Electricals Limited is the a power plant equipment manufacturer under Government of India. Their manufacturing facilities (factories) are located in various cities across India, including -Jagdishpur,...
72.4k views

@Reya · Aug 22, 2011

Written Test : Written test will be mostly of coding, puzzles and questions from Data Structures. Interview will be fully from coding and algorithms. Lots of rounds of interview will...
1.8k views

@Ankita Katdare · Sep 19, 2014

If you have been closely following the growth of Notion Ink tablets, you probably remember that the sales of Notion Ink Adam (launched in 2010) never took off and its...
5.8k views

@durga ch · Nov 18, 2009

Many might have already come across these words: but just a repea fort hose who dont know this man's speech! frankly speaking, Wipro Technologies is a competitive vendor and though...
1.8k views

@Ankita Katdare · Oct 4, 2013

A friend asked me this question, the other day - A lady buys goods worth Rs. 200 from a shop. (shopkeeper is selling the goods with zero profit). The lady...
223.9k views