View Feed
group-icon
Coffee Room
Discuss anything here - everything that you wish to discuss with fellow engineers.
12920 Members
Join this group to post and comment.
Kaustubh Katdare
Kaustubh Katdare • Dec 7, 2006

How to set OS selection timeout in GRUB?

I hope I titled the post appropriately 😀. I only get 4 seconds to select the OS on my machine.

I know that there's a setting which allows me to set the time to 15 seconds. Please tell me what/where is the setting 😒 ?

-The Big K-

p.s: The question is 'too basic' (??). I've not yet jumped out of Windows, you see 😉
desijays
desijays • Dec 8, 2006
okay, you never mentioned what distro you are using. But i'll presume you are using either an RPM based or DEB based distro.

for once stay at the computer while booting and within four seconds log into the linux OS.

After you are logged in, search for a file called /boot/grub/grub.conf (older versions) or /boot/grub/menu.lst (newer version). Either one of them are just plain normal text files. Open the file with a normal text editor (vi, emacs or alike).

Scroll down a bit. You will see an entry that says something like "timeout" and a few tabs away you will see a number. The number is the parameter in seconds. Change that parameter to the number of seconds you want.

I think your problem must be solved by now. 😀

peace
pad
pad • Dec 12, 2006
and then dont forget to run

#grub-install


this will actually make the changes effective
Kaustubh Katdare
Kaustubh Katdare • Dec 12, 2006
Thanks desijays & pad 😀

The problem has been solved


-The Big K-

Share this content on your social channels -