1. Home >
  2. Apps >
  3. Groups >

Folders hidden in Pendrive

Question asked by logiclover in #Coffee Room on Jan 17, 2008
logiclover
logiclover · Jan 17, 2008
Rank E2 - BEGINNER
My pen drive was affected by fun.exe virus. I started my XP in Safe mode and scanned my pen drive through AVG. It deleted all the infected files. Now I am not able to view folders in my Pen drive. I have tried Folder Option > Show hidden files
Still it is not working. But if I type the hidden folder name in the browser contents of the folders will appear. But for this I should remember the folder name.
I have tried the following two options also:
“Go to registry editor by running regedit in the run box.
Go to this key:
HKEY_CURRENT_USER\Software\Microsoft\
Windows\CurrentVersion\Explorer\Advanced
In the right hand area, double click hidden and change the value to 1″
****************************************************************
.1. Click “Start” -> “Run…” (or press Windows key + R)
2. Type “regedit” and click “Ok”.
3. Find the key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\SHOWALL
4. Look at the “CheckedValue” key… This should be a DWORD key. If it isn’t, delete the key.
5. Create a new key called “CheckedValue” as a DWORD (hexadecimal) with a value of 1.


But I can create new folders. There is no issue with the new folder and also Folders in other drives of my pc(c,d,e...) are behaving normally.Problem is with only the old folders in pendrive.



Please help. Posted in: #Coffee Room
mahul
mahul · Jan 19, 2008
Rank C1 - EXPERT
Have u checked whether ur folder option remains fixed at "show hidden files and folders" or reverts back to "do not show hidden files and folders" every time u reopen the folder options? Well if it does, this means u have not cleaned ur system of the viruses entirely. Then u can check out other posts here on ce regarding the same and try the options everyone has described. And if find that ur computer is perfectly normal except for those offending folders, though i can't explain why the thing is occurring unless there is a virus i can suggest a way to get the data that has been hidden. Just access the pen drive by command prompt and i think u will be able to see all ur folders.
logiclover
logiclover · Jan 20, 2008
Rank E2 - BEGINNER
Yes. I have already done what you have suggested. I recovered the data through command prompt. But the crazy thing is why it is happening? There is no problem in "do not show hidden folders or files". It is unmarked.

Any how thanks for your suggestion.
di0nysus
di0nysus · Jul 26, 2011
Rank E2 - BEGINNER
My man, AVG is a very poor antivirus. If your problems occured because of virus infection use a stronger anrivirus. Why don't u try a nod32, kasperky or Gdata? And after that if you folders don't become visible again reset them with a total comander (File -> Change attrubutes).
PraveenKumar Purushothaman
Rank A1 - PRO
Do try Virus, Spyware & Malware Protection | Microsoft Security Essentials as it is best. 😀 And for restoring your hidden files issue, please use A guide and tutorial on using ComboFix 😀 All the best! 😀
Ajith Mc
Ajith Mc · Aug 9, 2011
Rank E2 - BEGINNER
logiclover
Yes. I have already done what you have suggested. I recovered the data through command prompt. But the crazy thing is why it is happening? There is no problem in "do not show hidden folders or files". It is unmarked.

Any how thanks for your suggestion.
how did you recovered data through command prompt? could you pls tell how to do it?
RajdeepCE
RajdeepCE · Aug 12, 2011
Rank B3 - LEADER
logiclover
My pen drive was affected by fun.exe virus. I started my XP in Safe mode and scanned my pen drive through AVG. It deleted all the infected files. Now I am not able to view folders in my Pen drive. I have tried Folder Option > Show hidden files
Still it is not working. But if I type the hidden folder name in the browser contents of the folders will appear. But for this I should remember the folder name.
I have tried the following two options also:
“Go to registry editor by running regedit in the run box.
Go to this key:
HKEY_CURRENT_USER\Software\Microsoft\
Windows\CurrentVersion\Explorer\Advanced
In the right hand area, double click hidden and change the value to 1″
****************************************************************
.1. Click “Start” -> “Run…” (or press Windows key + R)
2. Type “regedit” and click “Ok”.
3. Find the key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\SHOWALL
4. Look at the “CheckedValue” key… This should be a DWORD key. If it isn’t, delete the key.
5. Create a new key called “CheckedValue” as a DWORD (hexadecimal) with a value of 1.


But I can create new folders. There is no issue with the new folder and also Folders in other drives of my pc(c,d,e...) are behaving normally.Problem is with only the old folders in pendrive.



Please help.

try following command in command prompt with administrator privilages

attrib -r -h -s I:\*.* \S \D
where I: is the drive letter of your removable media.

-Regards
coollanaka
coollanaka · Mar 3, 2012
Rank E2 - BEGINNER
it's simple thing do this 1- toot >> folder option >>view >> 2. check on "show hidden files and folder" . 3. UN-check on "hide protected operating system files".
PraveenKumar Purushothaman
Rank A1 - PRO
PS: It is not \S \D, it is /S /D
coollanaka
it's simple thing do this 1- toot >> folder option >>view >> 2. check on "show hidden files and folder" . 3. UN-check on "hide protected operating system files".
It works only if you had done the above thing!

You must log-in or sign-up to reply to this post.

Click to Log-In or Sign-Up