View Feed
group-icon
Coffee Room
Discuss anything here - everything that you wish to discuss with fellow engineers.
12838 Members
Join this group to post and comment.
prabhagharan
prabhagharan • Oct 20, 2008

ubuntu 8.04.1 LTS help

I Have installed ubuntu 8.04.1 LTS in my frnds computer.
After installing Some of my friends said that C/C++ compilers where inbuilt in linux OS.
So we tried to compile some C and C++ programs but non of it was compiled.😔
Why what is wrong with this ubuntu 8.04.1 LTS?
Do i need to install C/C++ compilers?
If so plz say how to install ?
plz give me clear instruction...
xero
xero • Oct 21, 2008
I bet you are looking for the traditional header files and you don't seem to find it 😀
For this you need the old gnu libraries and it may get hectic, so better search for new syntax for using the macros and header files, or if possible you can see the new gnu compiler version documents, and i think the version should be 4.2.2 or above !!
prabhagharan
prabhagharan • Oct 23, 2008
Thank you for your reply.
But i can't get it plz say me clearly because i am new to LINUX.
Prasad Ajinkya
Prasad Ajinkya • Oct 23, 2008
Have you installed gcc and the core libraries? Try sudo apt-get install gcc
prabhagharan
prabhagharan • Oct 24, 2008
ya kidakaka
i tried that but it gives some error message still i am not able to compile C/C++ codes :-(
prabhagharan
prabhagharan • Oct 25, 2008
Before this discussions i want to know whether this ubuntu 8.04.1 LTS has in built C/C++ compiler or not
prabhagharan
prabhagharan • Oct 25, 2008
why no replies from anyone
mahul
mahul • Oct 25, 2008
It might have or it might not. I do not use ubuntu distros so can't comment but someone will certainly answer that. What is more probable is that you went for a default selection of packages and missed out on gcc.
Try 'man gcc'. If gcc is indeed installed, this would open the manual for it. Else look in the rpm folder of the distro. You will find the gcc compiler somewhere. Try installing that. command would be rpm -ihv [filename]. (flags can be altered to suit your choice if you wish).
prabhagharan
prabhagharan • Oct 26, 2008
thankx man i will try it and report the errors

Share this content on your social channels -