View Feed
group-icon
PHP Programmers
Community for PHP Programmers : Ask questions, doubts and help each other get better at PHP
268 Members
Join this group to post and comment.
jatin-phoenix
jatin-phoenix • Jun 10, 2009

running php script using xampp

i installed xampp version 1.7.0.
after that i created a script test.php inside
htdocs folder.
i tried running it using
https://localhost/xampp/htdocs/test.php
https://localhost/xampp/test.php
https://localhost/test.php
it does not run and the error it gives is
object not found and error 404.
what do i do? somebody help!
Kaustubh Katdare
Kaustubh Katdare • Jun 10, 2009
The path would be https://localhost/test.php

Make sure you have apache running.

If that too doesn't work, first make sure you get XAMPP screen at cPanel®

If that fails, try cPanel®

Let us know what results you get.
jatin-phoenix
jatin-phoenix • Jun 10, 2009
i did what u told . this is the screen i am getting. i checked from apache panel. apache is running.
Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404

localhost
06/10/09 16:13:53
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8
Kaustubh Katdare
Kaustubh Katdare • Jun 10, 2009
Okay, follow these steps and let me know at what stage things go wrong -

1. Start XAMPP control panel.
2. Start Apache
3. Fire up Mozilla or IE.
4. Type cPanel® -> Should give you XAMPP page.
5. If #4 dosen't work, try cPanel® -> Should give you XAMPP page.
6. Go to https://localhost/test.php -> If the code is right, should produce results.

Now, post following information -

1. Your OS.
2. Complete path to "htdocs" folder.

Assumption: You've made a default-options install and haven't configured apache manually.
jatin-phoenix
jatin-phoenix • Jun 10, 2009
it works now biggie.
thanks a lot for the help.
Kaustubh Katdare
Kaustubh Katdare • Jun 11, 2009
jatin-phoenix
it works now biggie.
thanks a lot for the help.
Alright . Good to hear that! [​IMG]
jhbalaji
jhbalaji • Jul 26, 2009
You must first start it then goto localhost mate...

Share this content on your social channels -