View Feed
group-icon
Coffee Room
Discuss anything here - everything that you wish to discuss with fellow engineers.
12889 Members
Join this group to post and comment.
Kaustubh Katdare
Kaustubh Katdare • Nov 17, 2018

Hello Again! CrazyEngineers Got a Little Makeover and New Features

CrazyEngineers Gets A Makeover!

Welcome to revamped CrazyEngineers. This is our biggest makeover since our launch in May 2018. As you'd guess, we've listened to your feedback and have tried to include as much we could in the new design. 

You'll appreciate sticky sidebars, notifications with avatars, new 'Deals' app (we're working on it) and yeah - all your likes now show who liked your content! 

The new design prepares us for super exciting things we're working on already. You'll now see faster updates in coming days.

PS: If something looks out of place, just give your browser a refresh multiple times. If the problem stays, please do bring it to our notice.

Ankita Katdare
Ankita Katdare • Nov 17, 2018

Super excited about the new look of the website. Designed with user-friendliness in mind. ? 

Looking forward to hearing all that our members have to say about it.

The design looks nice for sure! CE has come a long way! Will be waiting for new apps and features as well.  

Kaustubh Katdare
Kaustubh Katdare • Nov 17, 2018

One small change to the way members are tagged. We only relied on first names, but now we search and display full name.

Major improvement to user suggestions is coming soon. 

Sticky sidebar is a big help. Did not see any avatars in the notifications. 

Kaustubh Katdare
Kaustubh Katdare • Nov 18, 2018

... we had to preserve the old notifications. All new notifications should get avatar of the notification sender. ? 

Got it. @Kaustubh , yours showed up right now. Good.

Kaustubh Katdare
Kaustubh Katdare • Nov 18, 2018

Also, you could click on the count of likes to know who liked. Please do give it a try.

Tried with iPad, Macair, Android and Windows. Did not work on any of them.

Kaustubh Katdare
Kaustubh Katdare • Nov 19, 2018

@Ramani Aswath sir, that is strange. Every use should be able to see the count of likes right besides the like button. Clicking on the count of likes should open a pop-up like this one -

IeCM-Screen%20Shot%202018-11-19%20at%2010.24.13%20AM.png

The only thing that could be causing issue on your machines is the cache. Could you please do the following-

1. If you are using Google Chrome or Safari - Selection option 'History' -> Show History / Clear History .

2. Then clear all the history; so that fresh CSS/JS files are fetched from the server. 

Refresh or Reload the page and you should be able to see the likes.

PS: I think this could be an issue with other CEans who've visited CE in the last ~4-5 days. I'll tag @Amit Jha , @Harshad Italiya, @saandeep sreerambatla to check and let us know if the new site is loading fine for them. 

One clear way to find that out is to check - both left and right sidebars are STICKY. Would really appreciate your support. 

Amol Jain
Amol Jain • Nov 19, 2018

Both sidebars are stick for me and I can see the pop up. Nice site!

Harshad Italiya
Harshad Italiya • Nov 19, 2018

Cool !
Love the new look and features.
@Kaustubh Katdare It loads fine for me.

I reported earlier that the side bars stick. No problem on that count. The like count is also visible. But nothing happens when I click both in Safari and in Firefox. I shall revert.

Kaustubh Katdare
Kaustubh Katdare • Nov 19, 2018

I checked on Mac + Safari and things seem to work. We're checking it again. @Ramani Aswath sir, are you using MacOS or Windows? 

I see a problem even though I have already logged in , I still see the advertisement on the top saying want to be part of the community , I mean the ad to sign up. 


I also see the signup now advertise on the right side of the page.

cleared cache, @Kaustubh katdare

ACT fibre cut reported. Net is too slow. Shall revert later.

Abhishek Rawal
Abhishek Rawal • Nov 19, 2018

Looks much better than previous version.

Folder icon when clicked on Topics drop down, doesn't look good. We need dislike button as well :D

Why don't we have option to login using e-mail address as well, like we used to have before new design was introduced ?

Good job, CE Team. 

Kaustubh Katdare
Kaustubh Katdare • Nov 19, 2018

Abhishek, we decided to skip the login with username/password functionality in this release because it was too much to handle. Be assured, it's coming really soon (maybe in the next few days).

This design update was necessary in order to support our upcoming features and apps. We've planned a release cycle; which means new stuff would be launched sooner than before. 

We already have seen 10x growth in registration after the new launch and are quite excited. 

PS: Groups are coming, soon! ? 

It’s getting curiouser and curiouser.

My Macbookair refuses my login.

Kaustubh Katdare
Kaustubh Katdare • Nov 19, 2018

@Ramani Aswath - are you getting any error message? It'd help us troubleshoot the issue. Requesting you to mail me the details of the error or any issue. 

While we work on bringing back email/password based login, social authentication happens on the social network. So it could be a temporary issue with the social service. 

However, I find it quite strange that you are not seeing likes overlay. 

Amulya Joshi
Amulya Joshi • Nov 20, 2018

Hi! I had visited this site long time ago but did not sign up. Visited again yesterday and decided to join. Very nice initiative to get all engineers together. 

Ankita Katdare
Ankita Katdare • Nov 20, 2018

@saandeep sreerambatla The advertisements will get updated soon. We are working on changing them. 

Kaustubh Katdare
Kaustubh Katdare • Nov 20, 2018

Advertisements are needed and allow CE to be run free of cost to all our fellow CEans. But I agree that we need a better advertising mechanism. We are experimenting with certain revenue channels. One idea was to introduce premium memberships; but that makes sense once we've expanded our overall offering. 

Would love to hear ideas. 

@Kaustubh Katdare , on all the usual login popup comes on. On the Android and Windows, I click on the Google link and I get logged in. On the Macbook for some reason nothing happens when I do the same operation. I am sent back to the login or signup screen. No messages.

Kaustubh Katdare
Kaustubh Katdare • Nov 20, 2018

I think it's mostly likely to be Cache. Could you please try clearing cache using these steps on Macbook -

1. If you are using Google Chrome or Safari - Selection option 'History' -> Show History / Clear History .

2. Then clear all the history; so that fresh CSS/JS files are fetched from the server.  


Will do and revert later to night.

There is a new twist. Links put into posts do not seem to post as clickable ones. Is it my local problem or do others find the same difficulty?

This happened to me three times today.

An update. Two of the above became clickable after fifteen minutes by themselves.

One more became alright. In the meanwhile I had made one more post. Till now this is still not clickable.

Kaustubh Katdare
Kaustubh Katdare • Nov 20, 2018

@Ramani Aswath sir, links are an issue ? . We're working on it. 

Another interesting  thing. On my Dell Desktop on Windows 10 'the click on the count of likes to know who liked' suddenly started working without my doing anything. 

We have to say with William Cowper:"God (and computer)moves in a mysterious way
His wonders to perform...

Kaustubh Katdare
Kaustubh Katdare • Nov 20, 2018

@Ramani Aswath sir, good to know likes are working fine on your machine now. It could be that Windows 10 machine just had a cycle of evolution and gained some AI. ? 

Rashmi Gandhi
Rashmi Gandhi • Nov 20, 2018

I'm loving the look of this site. Accessing from mobile. ? Downloads section looks quite good. Needs more resources from the community.

Ankita Katdare
Ankita Katdare • Nov 20, 2018

We are constantly working on improving the experience for our members. As said by @Kaustubh Katdare above, stay tuned for the upcoming releases as we have a lot planned out. ? ? 

The likes pop up now works on the iPad also.

 @Kaustubh Katdare , cleared all history on Safari and tried logging in. Unfortunately the problem remains the same as before on the MacBook Air.

Shall keep monitoring.

Kaustubh Katdare
Kaustubh Katdare • Nov 21, 2018

@Ramani Aswath sir, did you try using another browser on Chrome - like Safari? My best guess is that it could be some browser caching related issue. I'm not able to figure out. I tested with MacBook Air, Windows and multiple browsers - things seem to be working fine. 

I shall check it out. No real issue as I use iPad, where there are no problems.

Share this content on your social channels -